icon

Sygic GPS Navigation for iOS - Regional apps

Regional paid Premium app without trial option.

Compatibility & Requirements

Sygic app requires you to have a compatible Apple iOS device.

Requires iOS 9.0 or later. Compatible with iPhone, iPad, and iPod Touch (6th generation). This app is optimized for iPhone 5s, iPhone 6, iPhone 6 Plus, 6S, 6S Plus, and iPhone 7/7 Plus/8/8 Plus and iPhone X/XS/XS Max and XR.

Please note: Wi-Fi only iPads do not have a GPS receiver built in. Sygic GPS Navigation requires GPS functionality. In this case, it is necessary to have an external Bluetooth GPS receiver paired with your iPad.

Nie znalazłeś rozwiązania lub odpowiedzi?

Wyślij zapytanie

Powrót do spisu sekcji

How to restore previous purchases?

Are you happy with Sygic GPS Navigation?

Share it please

Wyślij zapytanie

Jeśli nie znalazłeś odpowiedzi na swoje pytanie w naszym FAQ, skontaktuj się z nami, wypełniając poniższe informacje. Nasz personel od wsparcia skontaktuje się z Tobą za pośrednictwem poczty e-mail w ciągu 48 godzin. Dziękujemy.

Twoje zapytanie zostało wysłane! Nasz personel przejrzy je i skontaktuje się z Tobą w ciągu 48 godzin. Dziękujemy.