icon

Sygic GPS Navigation for iOS (version 18.x)

Free app with option to subscribe to Premium+

Compatibility and Requirements

Sygic GPS navigation for iOS requires you to have a compatible Apple iOS device.

Requires iOS 12 or later. Compatible with iPhone, iPad, and iPod Touch (6th generation). This app is optimized for iPhone 5s, iPhone 6, iPhone 6 Plus, 6S, 6S Plus, and iPhone 7/7 Plus/8/8 Plus and iPhone X/XS/XS Max and XR, and latest iPhone 11, 11 Pro and 11 Pro Max, iPhone 12, iPhone 12 mini, iPhone 12 Pro Max, iPhone 12 Pro.
For iOS 9, 10 or 11, the last available Sygic version is 18.8.4 released in December 2020.

Please note: Wi-Fi only iPads do not have a GPS receiver built in. Sygic GPS Navigation requires GPS functionality. In this case, it is necessary to have an external Bluetooth GPS receiver paired with your iPad.

¿No ha encontrado la respuesta a su pregunta?

Presentar una solicitud

Regreso a la sección Descripción general

How to download and install Sygic GPS Navigation for free?

Contento con Sygic GPS Navigation?

Distribuid por favor

Presentar una solicitud

Si no ha encontrado la respuesta de la pregunta en nuestra sección de preguntas frecuentes, guía del usuario ni guías de video, póngase en contacto con nosotros completando los detalles a continuación. Nuestro equipo de atención al cliente le contactará por correo electrónico dentro de las 48 horas. Gracias.